It would be best viewed with Microsoft Internet Explorer 5.0 or Netscape 4.x